Shopping Hospedagem Fórum Contato
     
   O portal do desenvolvedor ASP Florianópolis-SC, Terça-feira - 23 de Outubro de 2018  
Busca

Menu do site
Efetuar Login
Usuário:

Senha:

 Esqueceu a senha?
Login automático

 Cadastre-se
Criando uma planilha de cálculo do Excel com o ASP
Avaliações: 24   -   Minha nota: Média Geral: 5  

Você sabia que é possível criar planilhas do Excel utilizando o ASP?
Vamos neste exemplo criar uma planilha que faça o cálculo de valores automáticamente.

Você verá como é bem simples fazer isto:

Veja abaixo uma tabela simples criada com qualquer editor de HTML

Valor1 Valor2 Total
4 3 =SOMA(A2:B2)

ATENÇÃO: Caso possua uma versão em inglês do Excel, utilize SUM no lugar de SOMA

Esta tabela quando aberta pelo excel, ira exibir no Total o valor 7, e quando qualquer um dos valores forem alterados, a soma será refeita.

Bom, praticamente é só isto, mas vamos usar apenas uma linha de código em ASP, que fará com usuário informe se deseja abrir ou salvar planilha do Excel em seu computador.

Response.ContentType = "application/vnd.ms-excel"


Clique aqui para ver este exemplo


Portanto, segue abaixo o código completo do exemplo:


Espero que este pequeno exemplo seja útil á todos.

Um grande abraço!

Fabiano Dias
fabiano@superasp.com.br

www.superasp.com.br
O portal do desenvolvedor ASP




SuperASP do Brasil Ltda

03.066.522/0001-84
Av. Rio Branco 433 - Centro - Florianopolis - SC
Contato

© 2001/2008 - Superasp do Brasil Ltda. Todos os direitos reservados